User Tag List

Results 1 to 9 of 9

Thread: Site and Forums not Optimised

  1. #1

    Default Site and Forums not Optimised

    Taking into consideration site demographics, the bulletin boards could really use some speed enhancements. With the assumption that most users accessing the site overall have raw browsing speeds of 10KB at best, running vBulletin is suicide. First is the fact that it is a full-featured, fancy forum application, but it wasn't made for usage in low-speed localities.

    Code:
    Downloaded: 1 files, 50K in 3.2s (15.5 KB/s)
    Converting banglagamer.com/index.html... 1-138
    
    Downloaded: 1 files, 161K in 8.2s (19.6 KB/s)
    Converting www.banglagamer.com/forums/index.html... 0-696
    Now, we all know that browsing speed is affected by mainly (1) rendering latency (the time it takes for your browser to reproduce the page from the server on your computer) and (2) processing/database latency (HTML, JavaScript + any other scripts or database retrieval, in this case PHP/MySQL and relaying that information across), aside from the obvious roundtrips. As such, the effective speed when browsing is much lower. For a detailed technical report, you can check the site and forum out at http://www.websiteoptimization.com/services/analyze/

    Normally, the apparent and obvious choice for a site like this would be PunBB (demo), but I understand that the userbase here would go for more eye-candy than performance, so a balance of both worlds would be PhpBB (demo). Both are PHP- and MySQL-based, and there should also be converters or migration scripts around.

    My main gripe is not with loading pages per se, but with replying to and editing posts - it takes like, forever.
    Last edited by mryellow; April 14th, 2010 at 12:43. Reason: added website report link

  2. #2
    Noblesse Oblige
    • CvP's Gadgets
      • Motherboard:
      • ASUS P8Z77 V Delux
      • CPU:
      • Intel Core i7 3770K @3.9GHz
      • RAM:
      • GSkill TridentX 2x8GB DDR3 @2400MHz
      • Hard Drive:
      • Crucial M4 256GB SSD; WD Caviar Black 2TB; Hitachi 250GB; Samsung S3 1.5TB; Hitachi 2TB
      • Graphics Card:
      • EVGA 980Ti 6GB
      • Display:
      • Samsung 17"+22"+22"
      • Sound Card:
      • Realtek HD Audio <internal>
      • Speakers/HPs:
      • Creative Inspire 5:1
      • Keyboard:
      • Razer BlackWidow Ultimate
      • Mouse:
      • G7
      • Power Supply:
      • Seasonic X 850W 80Plus Gold
      • Optical Drive:
      • External DVD-RW
      • USB Devices:
      • Logitech Carl Zeiss Tessar HD 1080p Webcam
      • UPS:
      • Mercury 1500VA with Large Lead-Acid Battery
      • Operating System:
      • Genuine Windows 10 Pro
      • Comment:
      • Everything packed in a NZXT Phantom 820
      • ISP:
      • Link3/Amber IT
      • Download Speed:
      • 10000
      • Upload Speed:
      • 10000
    CvP's Avatar
    Join Date
    Feb 2008
    Location
    Dhaka, Bangladesh
    Posts
    9,019

    Arrow Re: Site and Forums not Optimised

    PunBB and PHPBB, both are meh.
    Yes, vBulletin 4 is a little messed up, but it is still better than any other forum software out there.

    I'm pretty sure average speed of BG users is much higher than 10kBps. Then ones with too low speed can always turn off images from their browser for faster browsing.

    BG server CPU usage averages a mere 0.3% and RAM usage ~0.1%. It has a 100mbps unmetered full duplex connection. So it is not the server.

    Anyways, BG site is optimized as much as possible except:

    • extremely compressed html [not worth for the trouble it comes with]
    • gzip compressed files [enabled but with a low level to reduce server overhead]
    • using CDN [not possible without shitload of money]
    • turn off template names in vB [i need it for developing purpose]
    • compressing all images [not worth it]
    • sphinx search for forums [not possible without a lot of money]
    • using memcache [not possible without a lot of money; not needed for a small site like BG]


    What you can do to make your browsing faster in BG:

    • make sure browser cache is enabled*
    • dont use opera turbo
    • dont run torrents in background
    • uncheck display images in browser
    • use the mobile theme that will be available sometime this month

    *last i checked, Firefox loses *all* file cache if it is not shutdown properly.

    About posting/editing: vBulletin uses AJAX for these and AJAX is a little bit sensitive to connection quality.
    If you are experiencing a lot of packet loss, it will take like forever.


    And finally, a site like BG is not a bachelor's life that you can move to anywhere whenever you like.
    There are far too many complications involved in this switching not to mention we use genuine vBulletin which cost a lot.


    EDIT: I forgot to thank you for your concern. so thanks
    If you have any particular suggestion in mind, always feel free to post.
    I'm trying to reduce the forum count and possibly introduce forum tabs. that will at least let you load the forum-home in a jiffy.

    EDIT 2: If you don't want AJAX during posting/editing, double click the "reply"/"edit" buttons.
    Last edited by CvP; April 14th, 2010 at 14:41.
    The abuse of greatness is when it disjoins remorse from power.
    Please do not PM me for support. You will NOT get a reply. Post in the relevant forum section.

  3. #3

    Default Re: Site and Forums not Optimised

    Quote Originally Posted by CvP View Post
    <snip>

    And finally, a site like BG is not a bachelor's life that you can move to anywhere whenever you like.
    There are far too many complications involved in this switching not to mention we use genuine vBulletin which cost a lot.

    <snip>
    Don't worry, I have migrated a forum of 29,903 users and 802,834 posts from PhpBB to vBulletin (later adding vBadvanced), so I know how much work it takes (though maybe not for the other way around).

    Quote Originally Posted by CvP View Post
    <snip>

    EDIT 2: If you don't want AJAX during posting/editing, double click the "reply"/"edit" buttons.
    Now that actually solves everything, thanks! Strange how the little things are never obvious, initially.
    Last edited by mryellow; April 14th, 2010 at 21:28.

  4. #4
    Noblesse Oblige
    • CvP's Gadgets
      • Motherboard:
      • ASUS P8Z77 V Delux
      • CPU:
      • Intel Core i7 3770K @3.9GHz
      • RAM:
      • GSkill TridentX 2x8GB DDR3 @2400MHz
      • Hard Drive:
      • Crucial M4 256GB SSD; WD Caviar Black 2TB; Hitachi 250GB; Samsung S3 1.5TB; Hitachi 2TB
      • Graphics Card:
      • EVGA 980Ti 6GB
      • Display:
      • Samsung 17&quot;+22&quot;+22&quot;
      • Sound Card:
      • Realtek HD Audio &lt;internal&gt;
      • Speakers/HPs:
      • Creative Inspire 5:1
      • Keyboard:
      • Razer BlackWidow Ultimate
      • Mouse:
      • G7
      • Power Supply:
      • Seasonic X 850W 80Plus Gold
      • Optical Drive:
      • External DVD-RW
      • USB Devices:
      • Logitech Carl Zeiss Tessar HD 1080p Webcam
      • UPS:
      • Mercury 1500VA with Large Lead-Acid Battery
      • Operating System:
      • Genuine Windows 10 Pro
      • Comment:
      • Everything packed in a NZXT Phantom 820
      • ISP:
      • Link3/Amber IT
      • Download Speed:
      • 10000
      • Upload Speed:
      • 10000
    CvP's Avatar
    Join Date
    Feb 2008
    Location
    Dhaka, Bangladesh
    Posts
    9,019

    Default Re: Site and Forums not Optimised

    Quote Originally Posted by mryellow View Post
    Don't worry, I have migrated a forum of 29,903 users and 802,834 posts from PhpBB to vBulletin (later adding vBadvanced), so I know how much work it takes (though maybe not for the other way around).
    any board -> vB or IPB is usually non problematic. the opposite is usually PITA.
    Actually, we will lose tons of things if we go from vB to phpbb/pubbb or even IP.Board. So that is not an option for us.

    Quote Originally Posted by mryellow View Post
    Now that actually solves everything, thanks! Strange how the little things are never obvious, initially.
    glad to know.

    it is not so obvious actually. I bet not even 5% of the whole vB users know of this new vB feature.
    you don't encounter "double click" in web pages normally

    btw, which browser do you use? and which ISP?
    The abuse of greatness is when it disjoins remorse from power.
    Please do not PM me for support. You will NOT get a reply. Post in the relevant forum section.

  5. #5

    Default Re: Site and Forums not Optimised

    Quote Originally Posted by CvP View Post
    <snip>

    it is not so obvious actually. I bet not even 5% of the whole vB users know of this new vB feature.
    you don't encounter "double click" in web pages normally

    btw, which browser do you use? and which ISP?
    True enough, and there are always two parties to an arguement: http://www.vbulletin.org/forum/showthread.php?t=235535 (but I surmise that's a different problem - single-click does not work for them, whereas in our case it does)

    I'm on Chromium and sadly, "GP-INTERNET".

  6. #6
    Noblesse Oblige
    • CvP's Gadgets
      • Motherboard:
      • ASUS P8Z77 V Delux
      • CPU:
      • Intel Core i7 3770K @3.9GHz
      • RAM:
      • GSkill TridentX 2x8GB DDR3 @2400MHz
      • Hard Drive:
      • Crucial M4 256GB SSD; WD Caviar Black 2TB; Hitachi 250GB; Samsung S3 1.5TB; Hitachi 2TB
      • Graphics Card:
      • EVGA 980Ti 6GB
      • Display:
      • Samsung 17&quot;+22&quot;+22&quot;
      • Sound Card:
      • Realtek HD Audio &lt;internal&gt;
      • Speakers/HPs:
      • Creative Inspire 5:1
      • Keyboard:
      • Razer BlackWidow Ultimate
      • Mouse:
      • G7
      • Power Supply:
      • Seasonic X 850W 80Plus Gold
      • Optical Drive:
      • External DVD-RW
      • USB Devices:
      • Logitech Carl Zeiss Tessar HD 1080p Webcam
      • UPS:
      • Mercury 1500VA with Large Lead-Acid Battery
      • Operating System:
      • Genuine Windows 10 Pro
      • Comment:
      • Everything packed in a NZXT Phantom 820
      • ISP:
      • Link3/Amber IT
      • Download Speed:
      • 10000
      • Upload Speed:
      • 10000
    CvP's Avatar
    Join Date
    Feb 2008
    Location
    Dhaka, Bangladesh
    Posts
    9,019

    Default Re: Site and Forums not Optimised

    Chromium/Chrome is not the best browser for vB.
    The abuse of greatness is when it disjoins remorse from power.
    Please do not PM me for support. You will NOT get a reply. Post in the relevant forum section.

  7. #7

    Default Re: Site and Forums not Optimised

    Yes, there are a couple of bugs (some of which can be reproduced with Safari as well), but none that I'm facing across 3 regularly-visited vbulletin bbs. Anyway, I couldn't live without WebKit (trumps Gecko), so I think I can live with some minor yet-to-surface problems.

    Chromium Bug Search: "vbulletin"

    But if you're worried about misguided reports due to browser faults, fear not, for I always load up my pages in Opera, Firefox and IE 7 before hitting the send or reply button.

  8. #8
    Noblesse Oblige
    • CvP's Gadgets
      • Motherboard:
      • ASUS P8Z77 V Delux
      • CPU:
      • Intel Core i7 3770K @3.9GHz
      • RAM:
      • GSkill TridentX 2x8GB DDR3 @2400MHz
      • Hard Drive:
      • Crucial M4 256GB SSD; WD Caviar Black 2TB; Hitachi 250GB; Samsung S3 1.5TB; Hitachi 2TB
      • Graphics Card:
      • EVGA 980Ti 6GB
      • Display:
      • Samsung 17&quot;+22&quot;+22&quot;
      • Sound Card:
      • Realtek HD Audio &lt;internal&gt;
      • Speakers/HPs:
      • Creative Inspire 5:1
      • Keyboard:
      • Razer BlackWidow Ultimate
      • Mouse:
      • G7
      • Power Supply:
      • Seasonic X 850W 80Plus Gold
      • Optical Drive:
      • External DVD-RW
      • USB Devices:
      • Logitech Carl Zeiss Tessar HD 1080p Webcam
      • UPS:
      • Mercury 1500VA with Large Lead-Acid Battery
      • Operating System:
      • Genuine Windows 10 Pro
      • Comment:
      • Everything packed in a NZXT Phantom 820
      • ISP:
      • Link3/Amber IT
      • Download Speed:
      • 10000
      • Upload Speed:
      • 10000
    CvP's Avatar
    Join Date
    Feb 2008
    Location
    Dhaka, Bangladesh
    Posts
    9,019

    Default Re: Site and Forums not Optimised

    Quote Originally Posted by mryellow View Post
    Yes, there are a couple of bugs (some of which can be reproduced with Safari as well), but none that I'm facing across 3 regularly-visited vbulletin bbs. Anyway, I couldn't live without WebKit (trumps Gecko), so I think I can live with some minor yet-to-surface problems.

    Chromium Bug Search: "vbulletin"

    But if you're worried about misguided reports due to browser faults, fear not, for I always load up my pages in Opera, Firefox and IE 7 before hitting the send or reply button.
    I was referring to some of these problems which are not actually Chromium's fault but vB's.
    The abuse of greatness is when it disjoins remorse from power.
    Please do not PM me for support. You will NOT get a reply. Post in the relevant forum section.

  9. #9

    Default Re: Site and Forums not Optimised

    Ahh ok, I'll check em out, thanks.

Similar Threads

  1. For Members New to Internet Forums
    By Noob™ in forum Member Central
    Replies: 46
    Last Post: August 27th, 2013, 20:31
  2. Updates on New Site/Forums/Blogs
    By CvP in forum Announcements
    Replies: 42
    Last Post: January 28th, 2010, 14:31
  3. a small "work" for forums/site
    By CvP in forum Announcements
    Replies: 6
    Last Post: April 14th, 2009, 14:36
  4. newly added features in the site/forums
    By CvP in forum Feedback
    Replies: 22
    Last Post: January 30th, 2009, 02:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.22461 seconds with 14 queries.