User Tag List

Results 1 to 3 of 3

Thread: Games running slow all of a sudden

  1. #1

    Default Games running slow all of a sudden

    Hi everyone. I have been suffering from this issue for the last few months and since I joined here, I am thinking someone can help me out with it. So basically I am a Laptop gamer and my rig is not very powerful or anything like that. I only purchased it back in 2015 for my MBA plus I just wanted to know if I can run GTA V. So, everything went great up until October, 2018 when suddenly the lid of my laptop broke off from one side. However, I could use the laptop as usual and no performance issues or anything like that. But since it was difficult to use and carry, I gave it to a store in Multiplan Center where I actually purchased from back in 2015, and they fixed the joint of the lid. As I came home, I found everything is running slow from there on. I was getting good FPS on GTA V, Battlefield using my GPU, which is 930M Nvidia before this incident but now not at all. The funny thing is, I switched my graphics driver selection from my GPU to the CPU integrated one and Battlefield runs better than with my intel graphics than my gpu. So, I thought maybe it was downclocked by Nvidia updates or something so I rolled back the driver to an earlier version but it did not help. I tried cleaning the vents and everything but nothing is helping. Any suggestion would be highly appreciated. Thank you

  2. #2
    Member
    • sensei's Gadgets
      • Motherboard:
      • Gigabyte b250 hd3
      • CPU:
      • Intel I5 7400
      • RAM:
      • 8gb Gskill 2400bus
      • Hard Drive:
      • 1tb wdd blue, 120gb gskill m2 ssd
      • Graphics Card:
      • Gigabyte gtx 950
      • Display:
      • samsung 18.5inch (1360X768)
      • Sound Card:
      • built in
      • Speakers/HPs:
      • Microlab 2:1 / monk plus , KZ ate HiFi
      • Keyboard:
      • a4tech normal keyboard KR-83
      • Mouse:
      • Bloody A9
      • Controller:
      • none
      • Power Supply:
      • Cooler Master b500
      • Optical Drive:
      • Who use this nowadays Anyway?
      • Operating System:
      • Windows 10 64bit
      • Comment:
      • Poor man's fortress
      • ISP:
      • Speed Tech Online
      • Download Speed:
      • 4mbps
      • Upload Speed:
      • 2mbps
    sensei's Avatar
    Join Date
    Jul 2012
    Location
    Dhaka
    Posts
    3,629

    Default

    did you check the temperature of your igpu ? my assumption is when they reassemble the whole system might have forgot or misplaced the internal gpu cooler inside or somehow removed the thermal component and this is why your gpu is not fully performing to it's optimum state

  3. #3

    Default

    Quote Originally Posted by sensei View Post
    did you check the temperature of your igpu ? my assumption is when they reassemble the whole system might have forgot or misplaced the internal gpu cooler inside or somehow removed the thermal component and this is why your gpu is not fully performing to it's optimum state
    Hi. Thank you for your reply. I actually fixed it a bit, but opening up the laptop and cleaning the fan. At first, I was cleaning from the top of the fan, and turned on the laptop to see for certain whether it is actually working or not. So, as the fan was running, I suddenly noticed through the running fan that there is some dust underneath that seems to be stuck. So I managed to open the fan to some extent and cleaned underneath and trust me it was a mess. I am sure that they probably kept it somewhere untidy. Cause I remember seeing them removing dust from the top of the laptop when I went to pick it up, whereas it has just been 1 day they kept it. So, yeah after cleaning the dust underneath, the games started performing like before.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.14579 seconds with 13 queries.