User Tag List

Results 1 to 16 of 16

Thread: Sapphire 7970 OC w/ boost driver issue

  1. #1
    Member
    • mr_08's Gadgets
      • Motherboard:
      • Asus B75M+ || Gigabyte G41m combo
      • CPU:
      • Intel core i5 2500k @3.3ghz cooled by the CM V6GT || Intel dual core e5500 @4ghz with TT V1AX cooler
      • RAM:
      • Gskill RIPJAWS X SERIES 4gbx2 @ 1600mhz || adata xpg 2x2gb @1333mhz 7-7-7-20
      • Hard Drive:
      • samsung f3 500gb || wd 1tb , samsung 250gb
      • Graphics Card:
      • Sapphire 7970 OC 3GB w/ BOOST || Gigabyte 8800gts 512mb
      • Display:
      • Sony Bravia KDL42W700B || Samsung P2350, Samsung T190
      • Sound Card:
      • integrated
      • Speakers/HPs:
      • Genius G500v || cosonic headphone
      • Keyboard:
      • cm devastator mb24 , a4tech x7 g800 , logitech k260|| a4tech x7 g500,a4tech KB 28g
      • Mouse:
      • cm devastator ms2k , a4tech x7 X710 || a4tech office mouse, logitech m210
      • Controller:
      • logitech g13,logitech rp2,xbox 360 wireless controller,generic usb x 3
      • Power Supply:
      • xfx pro series 650w || delux 450w
      • Optical Drive:
      • liteon 24x w/ LT || asus dvd rw
      • USB Devices:
      • Transcend 16gb USB 3.0 || Transcend 16gb usb 2.0
      • UPS:
      • Apollo 1200va || Powerguard 650va
      • Operating System:
      • win7 ultimate sp1 || xp sp3
      • Comment:
      • alhamdulillah!duitai chole,kharap na :D
      • ISP:
      • Itbasebd || qubee
      • Download Speed:
      • 8mb || 4 mb
      • Upload Speed:
      • 8mb || 2mb

    Join Date
    Apr 2008
    Location
    dhaka
    Posts
    4,041

    Default Sapphire 7970 OC w/ boost driver issue

    installed the card 'Sapphire 7970 OC w/ boost' yesterday night and as expected amd comes up with stupid driver issues [i hope its driver issues ]

    first e amar config bole nei

    CPU-i5 2500k @ 3.3 stock with cm v6gt
    mobo-gigabyte z68 d2h
    ram-gskill ripjaws 4gbx2
    psu-xfx 650w
    hdd-samsung 500gb
    dvd-liteon
    and three fans,ei baire kichhui lagano nai.

    previously had the gigabyte 560ti oc inside the pc,just oita khule eita lagano hoise.

    got the card in,cd te jei driver chhilo oitai dilam [it was dated something like june 20 2012]

    game e dukhe dekhi stutter kortese,tarpor catalyst 12.11 install korlam with cap 12.10,but eki obostha!what to do?havent used amd cards for ages now,so really dont have much idea.any sort of help would be much appreciated but be specific.
    ami chhoto amake marbenna.-_- shob _ buira_gamer_

  2. #2
    Member
    • Fox Mulder's Gadgets
      • Motherboard:
      • Gigabyte GA-Z77-D3H Rev 1.1 (Currently dead) | Intel DH55TC
      • CPU:
      • Core i5 3470 @ 3.8 Ghz (Currently not used) | intel Core i7 860 @ 3.3 GHz
      • RAM:
      • Corsair Vengeance 1600 MHz 2x4GB
      • Hard Drive:
      • Western Digital Blue 1 Terrabyte
      • Graphics Card:
      • Sapphire HD 7950 Vapor-X OC With Boost 3GB GDDR5 || Gigabyte GTX 680 Windforce 4GB
      • Display:
      • Philips 191EL 19" LED @77 Hz
      • Sound Card:
      • Creative Sound Blaster Live! 24 Bit
      • Keyboard:
      • Corsair K70 RGB
      • Mouse:
      • A4Tech 2X Click
      • Power Supply:
      • Thermaltake Smart 650W Modular
      • Optical Drive:
      • Samsung DVD Writer
      • UPS:
      • Spark Power (!) 1200VA
      • Operating System:
      • Windows 10 Build 10162
      • Comment:
      • It gets the job done!
      • ISP:
      • BracNet
      • Download Speed:
      • 1 Mbps
      • Upload Speed:
      • 1 Mbps
    Fox Mulder's Avatar
    Join Date
    Jul 2009
    Location
    I don't live in a city.
    Posts
    5,182

    Default

    Did you do a clean install of the drivers, as in uninstall the nvidia drivers and everything, boot into safe mode, run driver sweeper, let it clean the driver remains and then boot into normal mode and install the regular drivers? And it wasn't a very good idea to install the drivers that came with the card, anyways, uninstall everything nvidia/amd related, then go into safe mode, do the driver sweeper thingy, then install 12.11 Drivers and see if that helps, or alternatively, you can download the latest beta of the Radeon Pro software and try to force triple buffering on some of the titles you play, as long as you play with vsync on, you will see gains. And also, once the game has started, press Alt+Enter to switch to windowed mode, then Alt+Enter to return to Fullscreen again, apparently this fixes a bug that limits the driver to cap the framerate to half of what your monitor's refresh rate is.
    Last edited by Fox Mulder; December 19th, 2012 at 11:31.

  3. #3
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • MSI X370 Gaming Pro
      • CPU:
      • Ryzen 1700 @3.7GHz (H100i v2)
      • RAM:
      • 2x8GB Trident Z 3600Mhz
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Sennheiser PC350SE + Phillips SPH9500
      • Keyboard:
      • CM QuickFire Stealth
      • Mouse:
      • FinalMouse Scream One | Logitech G403
      • Controller:
      • Steam Controller
      • Power Supply:
      • Corsair AX850
      • Operating System:
      • Windows 10 1703
      • ISP:
      • AmberIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    13,790

    Default

    Just plugging in the card was a mistake. Uninstall all Display Adapters from the device manager. Download Driver Fusion (previously known as Driver Sweeper) and run it in Safe mode. That should clean out all junk left by Nvidia and AMD driver.

    Load back into Windows and install 12.11 directly. And do yourself a favor, go into your BIOS for 2 minutes, up your CPU voltage to 1.32V and change clock multiplier to 45. If you BSOD, up voltage to 1.37 and be happy.

  4. #4
    Member
    • mr_08's Gadgets
      • Motherboard:
      • Asus B75M+ || Gigabyte G41m combo
      • CPU:
      • Intel core i5 2500k @3.3ghz cooled by the CM V6GT || Intel dual core e5500 @4ghz with TT V1AX cooler
      • RAM:
      • Gskill RIPJAWS X SERIES 4gbx2 @ 1600mhz || adata xpg 2x2gb @1333mhz 7-7-7-20
      • Hard Drive:
      • samsung f3 500gb || wd 1tb , samsung 250gb
      • Graphics Card:
      • Sapphire 7970 OC 3GB w/ BOOST || Gigabyte 8800gts 512mb
      • Display:
      • Sony Bravia KDL42W700B || Samsung P2350, Samsung T190
      • Sound Card:
      • integrated
      • Speakers/HPs:
      • Genius G500v || cosonic headphone
      • Keyboard:
      • cm devastator mb24 , a4tech x7 g800 , logitech k260|| a4tech x7 g500,a4tech KB 28g
      • Mouse:
      • cm devastator ms2k , a4tech x7 X710 || a4tech office mouse, logitech m210
      • Controller:
      • logitech g13,logitech rp2,xbox 360 wireless controller,generic usb x 3
      • Power Supply:
      • xfx pro series 650w || delux 450w
      • Optical Drive:
      • liteon 24x w/ LT || asus dvd rw
      • USB Devices:
      • Transcend 16gb USB 3.0 || Transcend 16gb usb 2.0
      • UPS:
      • Apollo 1200va || Powerguard 650va
      • Operating System:
      • win7 ultimate sp1 || xp sp3
      • Comment:
      • alhamdulillah!duitai chole,kharap na :D
      • ISP:
      • Itbasebd || qubee
      • Download Speed:
      • 8mb || 4 mb
      • Upload Speed:
      • 8mb || 2mb

    Join Date
    Apr 2008
    Location
    dhaka
    Posts
    4,041

    Default

    Quote Originally Posted by BFG9000 View Post
    Did you do a clean install of the drivers, as in uninstall the nvidia drivers and everything, boot into safe mode, run driver sweeper, let it clean the driver remains and then boot into normal mode and install the regular drivers? And it wasn't a very good idea to install the drivers that came with the card, anyways, uninstall everything nvidia/amd related, then go into safe mode, do the driver sweeper thingy, then install 12.11 Drivers and see if that helps, or alternatively, you can download the latest beta of the Radeon Pro software and try to force triple buffering on some of the titles you play, as long as you play with vsync on, you will see gains. And also, once the game has started, press Alt+Enter to switch to windowed mode, then Alt+Enter to return to Fullscreen again, apparently this fixes a bug that limits the driver to cap the framerate to half of what your monitor's refresh rate is.
    eto kahini kore game chalabo!!!

    anyways ami kalke ratei nvidia er shob driver uninstall kore latest 12.11/12.10 cap install korsilam but didnt run the driver sweeper thingy.game e kemon jani kore,ek kothai its not smooth but frames thik ase.ar triple buffering jodi catalyst theke on kori tahole toh puro pc atkaia atkaia chole.and i did some benchmarking with the unigine just now and the scores seem fine to me,or are they?

    - - - Updated - - -

    Quote Originally Posted by aayman View Post
    Just plugging in the card was a mistake. Uninstall all Display Adapters from the device manager. Download Driver Fusion (previously known as Driver Sweeper) and run it in Safe mode. That should clean out all junk left by Nvidia and AMD driver.

    Load back into Windows and install 12.11 directly. And do yourself a favor, go into your BIOS for 2 minutes, up your CPU voltage to 1.32V and change clock multiplier to 45. If you BSOD, up voltage to 1.37 and be happy.
    ok will do the driver fusion thing,and install 12.11.why change cpu clock?btw unigine score ki thikase naki onek kom?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	driver.jpg 
Views:	5 
Size:	152.6 KB 
ID:	26280   Click image for larger version. 

Name:	unigine2.jpg 
Views:	6 
Size:	520.3 KB 
ID:	26281   Click image for larger version. 

Name:	unigineextreme.jpg 
Views:	6 
Size:	483.3 KB 
ID:	26282  
    ami chhoto amake marbenna.-_- shob _ buira_gamer_

  5. #5
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • MSI X370 Gaming Pro
      • CPU:
      • Ryzen 1700 @3.7GHz (H100i v2)
      • RAM:
      • 2x8GB Trident Z 3600Mhz
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Sennheiser PC350SE + Phillips SPH9500
      • Keyboard:
      • CM QuickFire Stealth
      • Mouse:
      • FinalMouse Scream One | Logitech G403
      • Controller:
      • Steam Controller
      • Power Supply:
      • Corsair AX850
      • Operating System:
      • Windows 10 1703
      • ISP:
      • AmberIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    13,790

    Default

    Because you have a 2500k and you are running it at stock....it's like hiring a prostitute and having her do the dishes. Use it to it's full potential man!

    You score looks ok I guess, I'm not very familiar with 7970 Heaven scores.

    You can deal with RadeonPro later, first fix up the basic things.

  6. #6
    Member
    • mr_08's Gadgets
      • Motherboard:
      • Asus B75M+ || Gigabyte G41m combo
      • CPU:
      • Intel core i5 2500k @3.3ghz cooled by the CM V6GT || Intel dual core e5500 @4ghz with TT V1AX cooler
      • RAM:
      • Gskill RIPJAWS X SERIES 4gbx2 @ 1600mhz || adata xpg 2x2gb @1333mhz 7-7-7-20
      • Hard Drive:
      • samsung f3 500gb || wd 1tb , samsung 250gb
      • Graphics Card:
      • Sapphire 7970 OC 3GB w/ BOOST || Gigabyte 8800gts 512mb
      • Display:
      • Sony Bravia KDL42W700B || Samsung P2350, Samsung T190
      • Sound Card:
      • integrated
      • Speakers/HPs:
      • Genius G500v || cosonic headphone
      • Keyboard:
      • cm devastator mb24 , a4tech x7 g800 , logitech k260|| a4tech x7 g500,a4tech KB 28g
      • Mouse:
      • cm devastator ms2k , a4tech x7 X710 || a4tech office mouse, logitech m210
      • Controller:
      • logitech g13,logitech rp2,xbox 360 wireless controller,generic usb x 3
      • Power Supply:
      • xfx pro series 650w || delux 450w
      • Optical Drive:
      • liteon 24x w/ LT || asus dvd rw
      • USB Devices:
      • Transcend 16gb USB 3.0 || Transcend 16gb usb 2.0
      • UPS:
      • Apollo 1200va || Powerguard 650va
      • Operating System:
      • win7 ultimate sp1 || xp sp3
      • Comment:
      • alhamdulillah!duitai chole,kharap na :D
      • ISP:
      • Itbasebd || qubee
      • Download Speed:
      • 8mb || 4 mb
      • Upload Speed:
      • 8mb || 2mb

    Join Date
    Apr 2008
    Location
    dhaka
    Posts
    4,041

    Default

    Quote Originally Posted by aayman View Post
    Because you have a 2500k and you are running it at stock....it's like hiring a prostitute and having her do the dishes. Use it to it's full potential man!

    You score looks ok I guess, I'm not very familiar with 7970 Heaven scores.

    You can deal with RadeonPro later, first fix up the basic things.
    arrrey!!!ami toh oc korei chalai,amar pc er shob parts ee oc kora.just stability issue ase naki oita dekhar jonnei cpu stock korsi otherwise card ta laganor ageo 4.7 e chhilo

    dekhi abar shob remove kore fresh install marbo.
    ami chhoto amake marbenna.-_- shob _ buira_gamer_

  7. #7
    Member
    • Fox Mulder's Gadgets
      • Motherboard:
      • Gigabyte GA-Z77-D3H Rev 1.1 (Currently dead) | Intel DH55TC
      • CPU:
      • Core i5 3470 @ 3.8 Ghz (Currently not used) | intel Core i7 860 @ 3.3 GHz
      • RAM:
      • Corsair Vengeance 1600 MHz 2x4GB
      • Hard Drive:
      • Western Digital Blue 1 Terrabyte
      • Graphics Card:
      • Sapphire HD 7950 Vapor-X OC With Boost 3GB GDDR5 || Gigabyte GTX 680 Windforce 4GB
      • Display:
      • Philips 191EL 19" LED @77 Hz
      • Sound Card:
      • Creative Sound Blaster Live! 24 Bit
      • Keyboard:
      • Corsair K70 RGB
      • Mouse:
      • A4Tech 2X Click
      • Power Supply:
      • Thermaltake Smart 650W Modular
      • Optical Drive:
      • Samsung DVD Writer
      • UPS:
      • Spark Power (!) 1200VA
      • Operating System:
      • Windows 10 Build 10162
      • Comment:
      • It gets the job done!
      • ISP:
      • BracNet
      • Download Speed:
      • 1 Mbps
      • Upload Speed:
      • 1 Mbps
    Fox Mulder's Avatar
    Join Date
    Jul 2009
    Location
    I don't live in a city.
    Posts
    5,182

    Default

    That Triple Buffering option in the Catalyst Control Panel has affect in only Open GL based applications, and affects only if you have Vsync on so I dunno why you felt that after turning it on everything became jittery, for Direct3D based games Radeon Pro is a must, and trust me, this isn't too much of a hassle, I owned Graphics cards that needed kick start like a motor cycle too

    Driver: Catalyst Beta 12.11
    Application Profiles: 12.11 CAP 2

    And listen to aayman, I believe he is right, you need to overclock a bit, your processor is holding your card back, if you don't believe me, underclock your card by 200Mhz or so and you'll find.. Smoothness!

  8. #8
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • MSI X370 Gaming Pro
      • CPU:
      • Ryzen 1700 @3.7GHz (H100i v2)
      • RAM:
      • 2x8GB Trident Z 3600Mhz
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Sennheiser PC350SE + Phillips SPH9500
      • Keyboard:
      • CM QuickFire Stealth
      • Mouse:
      • FinalMouse Scream One | Logitech G403
      • Controller:
      • Steam Controller
      • Power Supply:
      • Corsair AX850
      • Operating System:
      • Windows 10 1703
      • ISP:
      • AmberIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    13,790

    Default

    Quote Originally Posted by BFG9000 View Post
    And listen to aayman, I believe he is right, you need to overclock a bit, your processor is holding your card back, if you don't believe me, underclock your card by 200Mhz or so and you'll find.. Smoothness!
    Nah I didn't mean a CPU bottleneck, I just saw stock clocks on a 2500k and questioned mankind's future for a while.

  9. #9
    Member
    • mr_08's Gadgets
      • Motherboard:
      • Asus B75M+ || Gigabyte G41m combo
      • CPU:
      • Intel core i5 2500k @3.3ghz cooled by the CM V6GT || Intel dual core e5500 @4ghz with TT V1AX cooler
      • RAM:
      • Gskill RIPJAWS X SERIES 4gbx2 @ 1600mhz || adata xpg 2x2gb @1333mhz 7-7-7-20
      • Hard Drive:
      • samsung f3 500gb || wd 1tb , samsung 250gb
      • Graphics Card:
      • Sapphire 7970 OC 3GB w/ BOOST || Gigabyte 8800gts 512mb
      • Display:
      • Sony Bravia KDL42W700B || Samsung P2350, Samsung T190
      • Sound Card:
      • integrated
      • Speakers/HPs:
      • Genius G500v || cosonic headphone
      • Keyboard:
      • cm devastator mb24 , a4tech x7 g800 , logitech k260|| a4tech x7 g500,a4tech KB 28g
      • Mouse:
      • cm devastator ms2k , a4tech x7 X710 || a4tech office mouse, logitech m210
      • Controller:
      • logitech g13,logitech rp2,xbox 360 wireless controller,generic usb x 3
      • Power Supply:
      • xfx pro series 650w || delux 450w
      • Optical Drive:
      • liteon 24x w/ LT || asus dvd rw
      • USB Devices:
      • Transcend 16gb USB 3.0 || Transcend 16gb usb 2.0
      • UPS:
      • Apollo 1200va || Powerguard 650va
      • Operating System:
      • win7 ultimate sp1 || xp sp3
      • Comment:
      • alhamdulillah!duitai chole,kharap na :D
      • ISP:
      • Itbasebd || qubee
      • Download Speed:
      • 8mb || 4 mb
      • Upload Speed:
      • 8mb || 2mb

    Join Date
    Apr 2008
    Location
    dhaka
    Posts
    4,041

    Default

    Quote Originally Posted by BFG9000 View Post
    That Triple Buffering option in the Catalyst Control Panel has affect in only Open GL based applications, and affects only if you have Vsync on so I dunno why you felt that after turning it on everything became jittery, for Direct3D based games Radeon Pro is a must, and trust me, this isn't too much of a hassle, I owned Graphics cards that needed kick start like a motor cycle too

    Driver: Catalyst Beta 12.11
    Application Profiles: 12.11 CAP 2

    And listen to aayman, I believe he is right, you need to overclock a bit, your processor is holding your card back, if you don't believe me, underclock your card by 200Mhz or so and you'll find.. Smoothness!
    This is why i didn't want to buy amd,baal marka driver!eto bhejal bhalo lage?i like plug and play stuff.i have no idea about what radeon pro is
    Btw stock i5 2500k isn't that bad
    ami chhoto amake marbenna.-_- shob _ buira_gamer_

  10. #10
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • MSI X370 Gaming Pro
      • CPU:
      • Ryzen 1700 @3.7GHz (H100i v2)
      • RAM:
      • 2x8GB Trident Z 3600Mhz
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Sennheiser PC350SE + Phillips SPH9500
      • Keyboard:
      • CM QuickFire Stealth
      • Mouse:
      • FinalMouse Scream One | Logitech G403
      • Controller:
      • Steam Controller
      • Power Supply:
      • Corsair AX850
      • Operating System:
      • Windows 10 1703
      • ISP:
      • AmberIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    13,790

    Default

    Quote Originally Posted by mr_08 View Post
    This is why i didn't want to buy amd,baal marka driver!eto bhejal bhalo lage?i like plug and play stuff.i have no idea about what radeon pro is
    Btw stock i5 2500k isn't that bad
    DID YOU DO THE CLEAN INSTALL YET? Oita age koro, tarpor baki shob dekha jabe.

  11. #11
    Member
    • Fox Mulder's Gadgets
      • Motherboard:
      • Gigabyte GA-Z77-D3H Rev 1.1 (Currently dead) | Intel DH55TC
      • CPU:
      • Core i5 3470 @ 3.8 Ghz (Currently not used) | intel Core i7 860 @ 3.3 GHz
      • RAM:
      • Corsair Vengeance 1600 MHz 2x4GB
      • Hard Drive:
      • Western Digital Blue 1 Terrabyte
      • Graphics Card:
      • Sapphire HD 7950 Vapor-X OC With Boost 3GB GDDR5 || Gigabyte GTX 680 Windforce 4GB
      • Display:
      • Philips 191EL 19" LED @77 Hz
      • Sound Card:
      • Creative Sound Blaster Live! 24 Bit
      • Keyboard:
      • Corsair K70 RGB
      • Mouse:
      • A4Tech 2X Click
      • Power Supply:
      • Thermaltake Smart 650W Modular
      • Optical Drive:
      • Samsung DVD Writer
      • UPS:
      • Spark Power (!) 1200VA
      • Operating System:
      • Windows 10 Build 10162
      • Comment:
      • It gets the job done!
      • ISP:
      • BracNet
      • Download Speed:
      • 1 Mbps
      • Upload Speed:
      • 1 Mbps
    Fox Mulder's Avatar
    Join Date
    Jul 2009
    Location
    I don't live in a city.
    Posts
    5,182

    Default

    Quote Originally Posted by mr_08 View Post
    This is why i didn't want to buy amd,baal marka driver!eto bhejal bhalo lage?i like plug and play stuff.i have no idea about what radeon pro is
    Btw stock i5 2500k isn't that bad
    If you had bought a GTX 680 instead, it would've gotten processor bound too, remember when the HD58XX cards came in? Those cards got bogged down by the processors at that time, and ppl started ranting, my age old nsluttias are better, etc.

    - - - Updated - - -

    @aayman in all the GTX 680/HD 7970 reviews I have not seen them running the processor at stock speeds, let him OC and see if it helps, I have a feeling it will.
    Last edited by Fox Mulder; December 19th, 2012 at 15:25.

  12. #12
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • MSI X370 Gaming Pro
      • CPU:
      • Ryzen 1700 @3.7GHz (H100i v2)
      • RAM:
      • 2x8GB Trident Z 3600Mhz
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Sennheiser PC350SE + Phillips SPH9500
      • Keyboard:
      • CM QuickFire Stealth
      • Mouse:
      • FinalMouse Scream One | Logitech G403
      • Controller:
      • Steam Controller
      • Power Supply:
      • Corsair AX850
      • Operating System:
      • Windows 10 1703
      • ISP:
      • AmberIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    13,790

    Default

    Quote Originally Posted by BFG9000 View Post
    @aayman in all the GTX 680/HD 7970 reviews I have not seen them running the processor at stock speeds, let him OC and see if it helps, I have a feeling it will.
    That's cause having a CPU bottleneck is not an option for them at all, and they need to show the MAX potential. Almost nothing will bottleneck his 7970. Even BF3 MP gets 99% usage when I'm running a single 670. I hit a CPU bottleneck when using SLI.

  13. #13
    Member
    • shoryuken-x's Gadgets
      • Motherboard:
      • msi
      • CPU:
      • frio die dheke rakha Fx 6300
      • RAM:
      • 8gb ( to power black x)
      • Hard Drive:
      • 1/2 tb
      • Graphics Card:
      • Radeon HD 7950
      • Display:
      • 21.5 lcd
      • Sound Card:
      • lagano hoy ni
      • Speakers/HPs:
      • Genius Gx Sw-1250
      • Keyboard:
      • Delux t15s
      • Mouse:
      • Mowa A40 Game Master (600tk) ^_^
      • Controller:
      • venge gese
      • Power Supply:
      • Tt toughpower XT 675
      • Optical Drive:
      • oikhane fan bosai disi tape method
      • USB Devices:
      • few here nd there
      • UPS:
      • 600va
      • Operating System:
      • win 8 evolution 2014 X64 /Win 8.1 heavier edition
      • Benchmark Scores:
      • jana nei
      • Comment:
      • silent htpc
      • ISP:
      • antbd
      • Download Speed:
      • 60+
      • Upload Speed:
      • Do
    shoryuken-x's Avatar
    Join Date
    Aug 2012
    Location
    Dhaka
    Posts
    893

    Default

    Quote Originally Posted by mr_08 View Post
    installed the card 'Sapphire 7970 OC w/ boost' yesterday night and as expected amd comes up with stupid driver issues [i hope its driver issues ]

    first e amar config bole nei

    CPU-i5 2500k @ 3.3 stock with cm v6gt
    mobo-gigabyte z68 d2h
    ram-gskill ripjaws 4gbx2
    psu-xfx 650w
    hdd-samsung 500gb
    dvd-liteon
    and three fans,ei baire kichhui lagano nai.

    previously had the gigabyte 560ti oc inside the pc,just oita khule eita lagano hoise.

    got the card in,cd te jei driver chhilo oitai dilam [it was dated something like june 20 2012]

    game e dukhe dekhi stutter kortese,tarpor catalyst 12.11 install korlam with cap 12.10,but eki obostha!what to do?havent used amd cards for ages now,so really dont have much idea.any sort of help would be much appreciated but be specific.

    listen to aayman bhaia. use driver fusion clean nividia/ati anywhere u find including physx , restart fresh get one 12.11 beta for amd ... install

  14. #14
    Member
    • mr_08's Gadgets
      • Motherboard:
      • Asus B75M+ || Gigabyte G41m combo
      • CPU:
      • Intel core i5 2500k @3.3ghz cooled by the CM V6GT || Intel dual core e5500 @4ghz with TT V1AX cooler
      • RAM:
      • Gskill RIPJAWS X SERIES 4gbx2 @ 1600mhz || adata xpg 2x2gb @1333mhz 7-7-7-20
      • Hard Drive:
      • samsung f3 500gb || wd 1tb , samsung 250gb
      • Graphics Card:
      • Sapphire 7970 OC 3GB w/ BOOST || Gigabyte 8800gts 512mb
      • Display:
      • Sony Bravia KDL42W700B || Samsung P2350, Samsung T190
      • Sound Card:
      • integrated
      • Speakers/HPs:
      • Genius G500v || cosonic headphone
      • Keyboard:
      • cm devastator mb24 , a4tech x7 g800 , logitech k260|| a4tech x7 g500,a4tech KB 28g
      • Mouse:
      • cm devastator ms2k , a4tech x7 X710 || a4tech office mouse, logitech m210
      • Controller:
      • logitech g13,logitech rp2,xbox 360 wireless controller,generic usb x 3
      • Power Supply:
      • xfx pro series 650w || delux 450w
      • Optical Drive:
      • liteon 24x w/ LT || asus dvd rw
      • USB Devices:
      • Transcend 16gb USB 3.0 || Transcend 16gb usb 2.0
      • UPS:
      • Apollo 1200va || Powerguard 650va
      • Operating System:
      • win7 ultimate sp1 || xp sp3
      • Comment:
      • alhamdulillah!duitai chole,kharap na :D
      • ISP:
      • Itbasebd || qubee
      • Download Speed:
      • 8mb || 4 mb
      • Upload Speed:
      • 8mb || 2mb

    Join Date
    Apr 2008
    Location
    dhaka
    Posts
    4,041

    Default

    Quote Originally Posted by aayman View Post
    DID YOU DO THE CLEAN INSTALL YET? Oita age koro, tarpor baki shob dekha jabe.
    Actually not yet
    Fifa notun kichhu install na korei onekta thik hoise,by doing some changes in the catalyst.battlefield 3 agey try korini, ekhon run korlam and it seems ok, call of duty is fine as well but still expect better performance.far cry 3 matro install disi shondhai try die dekhbo kemon chole.borderlands 2 wasn't smooth.

    - - - Updated - - -

    Quote Originally Posted by BFG9000 View Post
    If you had bought a GTX 680 instead, it would've gotten processor bound too, remember when the HD58XX cards came in? Those cards got bogged down by the processors at that time, and ppl started ranting, my age old nsluttias are better, etc.

    - - - Updated - - -

    @aayman in all the GTX 680/HD 7970 reviews I have not seen them running the processor at stock speeds, let him OC and see if it helps, I have a feeling it will.
    As i said earlier,i do oc my processor.otherwise the K series plus the cooler would be useless.just ajkei stock e chalachhi.i use my dual core @4ghz flat out,oita die 4.5 eo gesi
    Till now amar kachhe mone hoi nai pc is suffering from cpu bottleneck.I'll go back to 4.5ghz after I'm done with the driver fiasco!
    ami chhoto amake marbenna.-_- shob _ buira_gamer_

  15. #15
    Member
    • Fox Mulder's Gadgets
      • Motherboard:
      • Gigabyte GA-Z77-D3H Rev 1.1 (Currently dead) | Intel DH55TC
      • CPU:
      • Core i5 3470 @ 3.8 Ghz (Currently not used) | intel Core i7 860 @ 3.3 GHz
      • RAM:
      • Corsair Vengeance 1600 MHz 2x4GB
      • Hard Drive:
      • Western Digital Blue 1 Terrabyte
      • Graphics Card:
      • Sapphire HD 7950 Vapor-X OC With Boost 3GB GDDR5 || Gigabyte GTX 680 Windforce 4GB
      • Display:
      • Philips 191EL 19" LED @77 Hz
      • Sound Card:
      • Creative Sound Blaster Live! 24 Bit
      • Keyboard:
      • Corsair K70 RGB
      • Mouse:
      • A4Tech 2X Click
      • Power Supply:
      • Thermaltake Smart 650W Modular
      • Optical Drive:
      • Samsung DVD Writer
      • UPS:
      • Spark Power (!) 1200VA
      • Operating System:
      • Windows 10 Build 10162
      • Comment:
      • It gets the job done!
      • ISP:
      • BracNet
      • Download Speed:
      • 1 Mbps
      • Upload Speed:
      • 1 Mbps
    Fox Mulder's Avatar
    Join Date
    Jul 2009
    Location
    I don't live in a city.
    Posts
    5,182

    Default

    Quote Originally Posted by aayman View Post
    That's cause having a CPU bottleneck is not an option for them at all, and they need to show the MAX potential. Almost nothing will bottleneck his 7970. Even BF3 MP gets 99% usage when I'm running a single 670. I hit a CPU bottleneck when using SLI.
    Max potential is the need of the hour now.

  16. #16
    Banned
    • Devil May Cry's Gadgets
      • Motherboard:
      • |Asrock| z68 Extreme4 Gen3
      • CPU:
      • |Intel| Core i3 2100 @ 3.10GHz
      • RAM:
      • 8GB |Corsair Vengeance| LP @ 1600Mhz Dual Channel
      • Hard Drive:
      • |WD Caviar Black| 1TB (64mb Cache)
      • Graphics Card:
      • |Sapphire| HD Radeon 6850 1GB GDRR5
      • Display:
      • |DELL| E1912H
      • Speakers/HPs:
      • |Sony| 5:1 Surround Home Theater
      • Keyboard:
      • |a4tech| GK-85 (Wireless)
      • Mouse:
      • |a4tech| G3-220N (Wireless)
      • Controller:
      • |xBox 360| Original (Wired)
      • Power Supply:
      • 650w |Antec TruePower| TP-650 - 80+ Modular
      • Optical Drive:
      • |Asus| DVD-RW
      • USB Devices:
      • |WD 500GB| (Usb 3.0)
      • UPS:
      • |RED FOX| - C650B
      • Operating System:
      • Windows 7 x64
      • Comment:
      • Packed on |Antec 1200| USB 3.0 - Full Tower Gaming Case
      • ISP:
      • |Robi Sky|
      • Download Speed:
      • 24/KB-30/KB Constant

    Join Date
    Nov 2012
    Posts
    226

    Default

    Quote Originally Posted by aayman View Post
    Because you have a 2500k and you are running it at stock....it's like hiring a prostitute and having her do the dishes. Use it to it's full potential man!

    You score looks ok I guess, I'm not very familiar with 7970 Heaven scores.

    You can deal with RadeonPro later, first fix up the basic things.
    it's like hiring a prostitute and having her do the dishes. Use it to it's full potential man! :O best example ever

Similar Threads

  1. [Can't Believe] : Sapphire 7970 in UCC
    By avas911 in forum GPU
    Replies: 69
    Last Post: February 3rd, 2012, 01:56
  2. Sapphire 7970 arrived in ABU DHABI!!
    By naved777 in forum GPU
    Replies: 3
    Last Post: January 8th, 2012, 23:53
  3. X-fi Titanium vista 64bit driver issue
    By Extreme Noob in forum Technical Support
    Replies: 3
    Last Post: May 23rd, 2010, 18:10
  4. Sapphire 4850 x2 driver & performance issue
    By ЯV●FireBaLL in forum Technical Support
    Replies: 5
    Last Post: May 2nd, 2010, 01:02

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.28941 seconds with 15 queries.