User Tag List

Results 1 to 6 of 6

Thread: EVGA Bios update!!!

  1. #1
    Member
    • CODhunter's Gadgets
      • Motherboard:
      • EVGA z370 FTW
      • CPU:
      • i7 8700k
      • RAM:
      • 16GB G-Skill RGB 3000bus
      • Hard Drive:
      • 128GB Corsiar SSD+2TB SSHD+1TB WD
      • Graphics Card:
      • Gigabyte GTX 1080ti extrem
      • Display:
      • Samsung 23.6' 4K
      • Sound Card:
      • Built-in
      • Keyboard:
      • WV-Klong
      • Mouse:
      • Razor elite
      • Power Supply:
      • EVGA Supernova 650wat
      • Operating System:
      • Windows 10 (pirated)
    CODhunter's Avatar
    Join Date
    Nov 2009
    Posts
    1,178

    Arrow EVGA Bios update!!!

    Just bought an EVGA 1070 FTW. Yes, there is heat issue. The back plate got very hot when there is default fan setting. So i am setting fan speed to 50% every time i play a game.
    So need helping hand.....how to update GPU bios.
    TIA, TOTA, Salik, Kaowa... plz help

  2. #2
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • Asrock Z370 Extreme4
      • CPU:
      • Intel 8700K @5.0ghz w/ Cryorig R1
      • RAM:
      • 2x8GB Trident Z 3600Mhz @3200CL14
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Phillips x2 HR
      • Keyboard:
      • Zowie Celeritas II
      • Mouse:
      • Razer Viper Ultimate
      • Controller:
      • Xbox One
      • Power Supply:
      • Corsair AX860
      • Operating System:
      • Windows 10 1909
      • ISP:
      • AalokIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    14,026

    Default

    If you just bought it then it comes with the thermal fix which does mean that the back-plate will get hot (part of the fix).

  3. #3
    Member
    • CODhunter's Gadgets
      • Motherboard:
      • EVGA z370 FTW
      • CPU:
      • i7 8700k
      • RAM:
      • 16GB G-Skill RGB 3000bus
      • Hard Drive:
      • 128GB Corsiar SSD+2TB SSHD+1TB WD
      • Graphics Card:
      • Gigabyte GTX 1080ti extrem
      • Display:
      • Samsung 23.6' 4K
      • Sound Card:
      • Built-in
      • Keyboard:
      • WV-Klong
      • Mouse:
      • Razor elite
      • Power Supply:
      • EVGA Supernova 650wat
      • Operating System:
      • Windows 10 (pirated)
    CODhunter's Avatar
    Join Date
    Nov 2009
    Posts
    1,178

    Default

    Quote Originally Posted by aayman View Post
    If you just bought it then it comes with the thermal fix which does mean that the back-plate will get hot (part of the fix).
    no it didnt :/
    so need to fix it now bro. helpppppppppp me

  4. #4
    Forum Staff
    • aayman's Gadgets
      • Motherboard:
      • Asrock Z370 Extreme4
      • CPU:
      • Intel 8700K @5.0ghz w/ Cryorig R1
      • RAM:
      • 2x8GB Trident Z 3600Mhz @3200CL14
      • Hard Drive:
      • 960 EVO 250GB + SanDisk SSDX 960GB + 1TB WD Black
      • Graphics Card:
      • EVGA 1070 FTW
      • Display:
      • ASUS PG279Q + Dell U2312HM
      • Sound Card:
      • Creative Sound Blaster Zx
      • Speakers/HPs:
      • Phillips x2 HR
      • Keyboard:
      • Zowie Celeritas II
      • Mouse:
      • Razer Viper Ultimate
      • Controller:
      • Xbox One
      • Power Supply:
      • Corsair AX860
      • Operating System:
      • Windows 10 1909
      • ISP:
      • AalokIT
    aayman's Avatar
    Join Date
    Jul 2008
    Posts
    14,026

    Default

    http://www.evga.com/thermalmod/

    scroll down for download link.

    - - - Updated - - -

    Process is very simple. Download the appropriate version and run it. Close all applications before you do so.

    Uou can just just update the Primary bios. To update the secondary you need to switch a pin on th GPU physically.

  5. #5
    Moderator
    • minitt's Gadgets
      • Motherboard:
      • Asus Sabertooth Z170 S
      • CPU:
      • Intel Core i7 6700K
      • RAM:
      • Corsair Vengence 3200mhz White Led
      • Hard Drive:
      • Samsung 970 EVO 1TB+ 830 (128GB)+2TB mech HDD
      • Graphics Card:
      • Evga 1080 TI Sc 11GB
      • Display:
      • Samsung KS8000 55"
      • Sound Card:
      • On board
      • Speakers/HPs:
      • Yamaha Reference Monitor
      • Keyboard:
      • Logitech G710+
      • Mouse:
      • Logitech G900 Chaos Spectrum
      • Power Supply:
      • Antec HCG-620M Modular
      • Optical Drive:
      • Nai
      • UPS:
      • dont need 1
      • Operating System:
      • Genuine Windows 10
      • ISP:
      • TELUS optical
      • Download Speed:
      • 75Mbps
      • Upload Speed:
      • 30mbps
    minitt's Avatar
    Join Date
    Feb 2008
    Location
    dhaka
    Posts
    4,261

    Default

    Quote Originally Posted by CODhunter View Post
    no it didnt :/
    so need to fix it now bro. helpppppppppp me
    is this Mr. Shajib ?

  6. #6
    Member
    • CODhunter's Gadgets
      • Motherboard:
      • EVGA z370 FTW
      • CPU:
      • i7 8700k
      • RAM:
      • 16GB G-Skill RGB 3000bus
      • Hard Drive:
      • 128GB Corsiar SSD+2TB SSHD+1TB WD
      • Graphics Card:
      • Gigabyte GTX 1080ti extrem
      • Display:
      • Samsung 23.6' 4K
      • Sound Card:
      • Built-in
      • Keyboard:
      • WV-Klong
      • Mouse:
      • Razor elite
      • Power Supply:
      • EVGA Supernova 650wat
      • Operating System:
      • Windows 10 (pirated)
    CODhunter's Avatar
    Join Date
    Nov 2009
    Posts
    1,178

    Default

    nop

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.18000 seconds with 13 queries.