User Tag List

Results 1 to 1 of 1

Thread: Cannot enter into UEFI BIOS settings in ASUS Z97

  1. #1
    • DEXTER's Gadgets
      • Motherboard:
      • ASUS Z97-K
      • CPU:
      • Intel Core i7 4790K @ 4.00 GHz cooled with Tt NIC I31
      • RAM:
      • 32GB (4x8GB) Kingston HyperX 2400 MHz
      • Hard Drive:
      • Samsung 850 Pro 256GB + Segate 2TB SSHD + WD Green 2TB
      • Graphics Card:
      • MSI GTX 970 4GB Twin Frozer
      • Display:
      • ASUS MX239H 1080p IPS
      • Sound Card:
      • On board Realtek Sh*t
      • Speakers/HPs:
      • Logitech Z623 + Sennheiser HD 558
      • Keyboard:
      • Corsair K70 RGB Mechanical
      • Mouse:
      • CM Havoc
      • Controller:
      • None. I freakin' hate controllers
      • Power Supply:
      • CM V750
      • Optical Drive:
      • ASUS DVD Writer
      • USB Devices:
      • Ugh, don't have the time and/or energy to list 'em all
      • UPS:
      • Transnet 1200 VA + Good ol' Rahimafrooz 600 VA
      • Operating System:
      • Win 10 Pro x64 + Ubuntu 14.04 Dual Boot
      • Comment:
      • Keeps me occupied
      • ISP:
      • BTCL
      • Download Speed:
      • 8 Mbps
      • Upload Speed:
      • 5 Mbps
      • Console:
      • 128
    DEXTER's Avatar
    Join Date
    Oct 2011

    Exclamation Cannot enter into UEFI BIOS settings in ASUS Z97

    Hi guys,
    I've just finished building a system with ASUS Z97-K. Booted up the machine and on startup the screen says Press DEL or F2 to enter UEFI BIOS settings as it should but nothing happens if I press DEL or F2. I think the mobo isn't recognizing the keyboard. The num lock lights up at the beginning and then it goes off and nothing happens. I've tried with both USB and PS/2 keyboard but no luck. Let me assure you that the USB keyboard is okay. I tested it on my laptop through and it's working fine.

    Another interesting thing is I can enter into the boot device selection menu using F8 and then enter into UEFI from there. So I guess it's the firmware that's faulty am I right? Would flashing it with a newer BIOS update fix it or I need to contact to the servicing centre from where I bought?

    My specs:
    Intel 4790K
    ASUS Z97-K
    Kingston HyperX 32GB
    Samsung 850 Pro 256 GB
    Cooler Master V750 PSU

    - - - Updated - - -

    Never mind. I fixed it by myself. I was correct, that pre-loaded firmware was faulty. Updating to a newer BIOS version did the trick.
    Last edited by DEXTER; June 15th, 2015 at 21:21.
    "People fake a lot of human interactions, but I feel like I fake them all, and I fake them very well, that's my burden, I guess."

Similar Threads

  1. Replies: 43
    Last Post: November 23rd, 2015, 06:43
  2. Replies: 3
    Last Post: January 26th, 2014, 07:30
  3. HDD does not show up randomly in BIOS/UEFI
    By dipanzan in forum Technical Support
    Replies: 23
    Last Post: June 26th, 2013, 00:51
  4. Asus M4a87TD bios update help
    By Shadowfax in forum Technical Support
    Replies: 4
    Last Post: December 19th, 2011, 05:21
  5. Can't enter BIOS! Please help...
    By salmanshah in forum Technical Support
    Replies: 10
    Last Post: October 6th, 2011, 22:45

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 0.14803 seconds with 14 queries.