User Tag List

Results 1 to 5 of 5

Thread: problem with XFX 5670 Card

  1. #1
    Member
    • ehossain's Gadgets
      • Motherboard:
      • Intel DH55PJ
      • CPU:
      • Core i5 760
      • RAM:
      • 4GB DDR3
      • Hard Drive:
      • 500 GB samsung
      • Graphics Card:
      • XFX HD 5670 1GB DDR5
      • Display:
      • 18.5 inch samsung LED
      • Operating System:
      • Windows 7

    Join Date
    Dec 2010
    Posts
    3

    Default problem with XFX 5670 Card

    hi all

    I have recently bought a system with XFX 5670 graphics card. i didnt bought a extra psu with the system cause the vendor which i bought it from said that the casing had enough power supply to run that card. the casing is Gigabyte GZ-PA . later i saw it has 500w + power supply.

    everything was running well for a week or so. game was running smoothly (i usually play wow catacysm). but from today my pc started to hang after boot and windows logo. it shows yellow or white striped screen at hang . i had to manually shutdown pc. btw i am using windows 7 32 bit os. i have searched on support forums some says it because of the drivers or psu . i have also installed new driver in safe mode . so my question is it for my psu i am having this issues ? please help me out on this

    Thanks in advance!

  2. #2
    Member
    • Mohiuddin's Gadgets
      • Motherboard:
      • Asus Sabertooth X58
      • CPU:
      • Xeon X5650
      • RAM:
      • 8gb gskill ripjaw
      • Hard Drive:
      • Western Digital 1TB blue
      • Graphics Card:
      • Zotac GTX670 4GB
      • Display:
      • now with TV
      • Sound Card:
      • built in
      • Speakers/HPs:
      • 2:1
      • Keyboard:
      • Logitech
      • Mouse:
      • Logitech
      • Controller:
      • Nai
      • Power Supply:
      • Gigabyte 1200w OdinPro
      • Optical Drive:
      • Generic
      • UPS:
      • Apatoto nai
      • Operating System:
      • win 7
      • ISP:
      • Netvision
      • Download Speed:
      • Janina, 3Mbps may be
      • Upload Speed:
      • Don't upload...

    Join Date
    Nov 2010
    Location
    Uttara,dhaka
    Posts
    4,165

    Default Re: problem with XFX 5670 Card

    ^I think it is n't d issue of psu... try uninstall all gfx driver in safemode.then start normally...if it is showing normally,then install 10.10e hotfix...if not ...then try reinstalling d win7...if still d problem persist then try changing psu.

    ---------- Post added at 15:37 ---------- Previous post was at 15:36 ----------

    And set everything default 2 ur ccc.

  3. #3
    Member
    • ehossain's Gadgets
      • Motherboard:
      • Intel DH55PJ
      • CPU:
      • Core i5 760
      • RAM:
      • 4GB DDR3
      • Hard Drive:
      • 500 GB samsung
      • Graphics Card:
      • XFX HD 5670 1GB DDR5
      • Display:
      • 18.5 inch samsung LED
      • Operating System:
      • Windows 7

    Join Date
    Dec 2010
    Posts
    3

    Default Re: problem with XFX 5670 Card

    thanks for the quick reply i will try that when i get back home.

  4. #4
    Member
    • fishd990's Gadgets
      • Motherboard:
      • Intel DH55HC
      • CPU:
      • RAM:
      • 2 GB DDR3
      • Hard Drive:
      • Samsung HD322HJ (320 GB) & Transcend Storejet (TM)25 Mobile (160 GB External)
      • Graphics Card:
      • Sapphire HD 5770 1 GB DDR 5
      • Display:
      • Samsung Syncmaster 2243BWX (22")
      • Sound Card:
      • ATI High Defination Audio Bus
      • Speakers/HPs:
      • Microlab 2:1
      • Keyboard:
      • Logitech K400
      • Mouse:
      • Logitech K400
      • Controller:
      • XBox 360 Controller for PC (Chinese)
      • Power Supply:
      • Thermaltake TR2- 500 W
      • Optical Drive:
      • Samsung DVD RW
      • USB Devices:
      • Bluetooth, Printer (HP Laserjet 1010), Scanner (HP Scanjet 4370)
      • UPS:
      • 800 VA (Gives upto 15 Min to my PC)
      • Operating System:
      • Windows 7 Ultimate
      • Comment:
      • :)
      • ISP:
      • BTCL Broadband 256 Kbps
      • Download Speed:
      • 60 (Avarage)
      • Upload Speed:
      • 30 (Avarage)
    fishd990's Avatar
    Join Date
    Jul 2009
    Location
    ▐█████
    Posts
    779

    Default Re: problem with XFX 5670 Card

    I had a almost similar problem. Can you tell me is it only the display or the whole PC hangs? I had a problem where the PC starts but the display failed.

    Do you get the windows start-up sound while the screen hangs. If so then you're problem is almost similar to mine, and in that case all those suggestions will not work. Also try the connecting and reconnecting the monitor while the yellow striped screen is displayed. If you find out that its same as my problem, then please inform how did you solve it. Thanks

    Read more if you want:
    http://banglagamer.com/forums/showth...ed-Help-Advice.

    Quote Originally Posted by Mohiuddin View Post
    ^I think it is n't d issue of psu... try uninstall all gfx driver in safemode.then start normally...if it is showing normally,then install 10.10e hotfix...if not ...then try reinstalling d win7...if still d problem persist then try changing psu.

    ---------- Post added at 15:37 ---------- Previous post was at 15:36 ----------

    And set everything default 2 ur ccc.
    Whats the 10.10e hotfix for? How can i download it?
    Last edited by fishd990; December 9th, 2010 at 19:51.

  5. #5
    Member
    • Mohiuddin's Gadgets
      • Motherboard:
      • Asus Sabertooth X58
      • CPU:
      • Xeon X5650
      • RAM:
      • 8gb gskill ripjaw
      • Hard Drive:
      • Western Digital 1TB blue
      • Graphics Card:
      • Zotac GTX670 4GB
      • Display:
      • now with TV
      • Sound Card:
      • built in
      • Speakers/HPs:
      • 2:1
      • Keyboard:
      • Logitech
      • Mouse:
      • Logitech
      • Controller:
      • Nai
      • Power Supply:
      • Gigabyte 1200w OdinPro
      • Optical Drive:
      • Generic
      • UPS:
      • Apatoto nai
      • Operating System:
      • win 7
      • ISP:
      • Netvision
      • Download Speed:
      • Janina, 3Mbps may be
      • Upload Speed:
      • Don't upload...

    Join Date
    Nov 2010
    Location
    Uttara,dhaka
    Posts
    4,165

    Default Re: problem with XFX 5670 Card

    ^it is just 5th time fixed 10.10 catalyst.it working better than 10.11 in my pc.and in crysis it give 8% improved performance than 10.8 with my 5770.
    Here is d dl link
    http://www.techpowerup.com/downloads...0e-Hotfix.html

Similar Threads

  1. XFX ATI 5670 problem
    By shuvo89 in forum Technical Support
    Replies: 23
    Last Post: December 2nd, 2010, 03:35
  2. Closed XFX 8400GS 512MB DDR2 Graphics Card
    By |-<NOSALIS>-| in forum Shop - Gadgets
    Replies: 4
    Last Post: September 4th, 2010, 12:50
  3. Want to Exchange i want to Exchange my XFX 8600 GT XXX Edition Graphics card
    By knroeoueqisk in forum Shop - Gadgets
    Replies: 1
    Last Post: April 14th, 2010, 05:58
  4. Tv Card problem
    By sameev29 in forum Others PC Hardware
    Replies: 2
    Last Post: April 19th, 2009, 02:40
  5. Problem in XFX hd4650 ddr2 1024MB
    By Cyber_Shot in forum GPU
    Replies: 22
    Last Post: March 23rd, 2009, 20:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.17401 seconds with 14 queries.