User Tag List

Results 1 to 7 of 7

Thread: Is my GPU dead? :(

  1. #1

    Default Is my GPU dead? :(

    I have a Sapphire HD 7750. I overclocked it once or twice without any problem. Anyway, 1 month later, I started seeing weird pixelation in 3D models. It only happens when rendering 3D models. To understand my problem, check this image link:
    Click image for larger version. 

Name:	JqkIYlM.jpg 
Views:	1310 
Size:	157.5 KB 
ID:	36219
    I tried sweeping the drivers and re-installing them. My GPU runs at about 43C under load. Is my GPU gone for good? If this happened to anybody else and you got it fixed, please let me know. Also, does anybody know good repairshops who can fix GPUs? I heard their life can be prolonged anywhere from a week to 6 months. Prolonging 3 months will do until i get a new one. Thanks in advance.

  2. #2
    Member
    • VANGUARD's Gadgets
      • Motherboard:
      • ASUS ROG Maximus X Hero
      • CPU:
      • Intel Core i7 8700K 5.2Ghz @Corsair H115i
      • RAM:
      • Gskill Ripjaws V 3466MHz 2x8GB
      • Hard Drive:
      • Zotac SSD 480GB Premium + Seagate Barracuda 2TB
      • Graphics Card:
      • Zotac GTX 1080Ti Amp! Extreme
      • Display:
      • ASUS VX24AH, 1440p
      • Sound Card:
      • ROG SupremeFX
      • Speakers/HPs:
      • Microlab M-910/Logitech UE 200vm
      • Keyboard:
      • Corsair STRAFE-CherryRED
      • Mouse:
      • Logitech G602 @Tt Pyrrhus
      • Controller:
      • Xbox One Wireless
      • Power Supply:
      • Antec EDGE 650w
      • Optical Drive:
      • Samsung SH-224FB
      • USB Devices:
      • Everything
      • UPS:
      • Micro UVL-1500 Long Backup
      • Operating System:
      • Windows 10 Pro x64
      • Comment:
      • The workhorse
      • ISP:
      • The Net Heads
    VANGUARD's Avatar
    Join Date
    Jun 2009
    Location
    Dhaka
    Posts
    10,097

    Default

    Quote Originally Posted by Ayat Ahmed View Post
    I have a Sapphire HD 7750. I overclocked it once or twice without any problem. Anyway, 1 month later, I started seeing weird pixelation in 3D models. It only happens when rendering 3D models. To understand my problem, check this image link:
    Click image for larger version. 

Name:	JqkIYlM.jpg 
Views:	1310 
Size:	157.5 KB 
ID:	36219
    I tried sweeping the drivers and re-installing them. My GPU runs at about 43C under load. Is my GPU gone for good? If this happened to anybody else and you got it fixed, please let me know. Also, does anybody know good repairshops who can fix GPUs? I heard their life can be prolonged anywhere from a week to 6 months. Prolonging 3 months will do until i get a new one. Thanks in advance.
    Why even trying to overclock that third class gpu? And yes, you card is probably damaged.

  3. #3
    Member
    • Sybaris Caesar's Gadgets
      • Motherboard:
      • Intel DH61WW B3 Rev.
      • CPU:
      • Intel Core i5 2400 3.10 Ghz
      • RAM:
      • Kingston KVR1333D3N9/4G 4GB DDR3 1333 Mhz
      • Hard Drive:
      • Seagate Barracuda 7200.12 1TB 7200 RPM
      • Graphics Card:
      • Leadtek Winfast GTX 560 ti 1GB GDDR5 822/1644/4008
      • Sound Card:
      • Onboard
      • Keyboard:
      • Thermaltake Commander
      • Mouse:
      • Logitech G402
      • Controller:
      • Original Xbox 360 Wireless
      • Power Supply:
      • Cooler Master G550M
      • Optical Drive:
      • Samsung SH222 22x DVD Writer
      • UPS:
      • Orlando 800va(packet e lekha apollo)
      • Operating System:
      • Windows 8.1 Pro x64
      • Upload Speed:
      • ∞
    Sybaris Caesar's Avatar
    Join Date
    May 2012
    Location
    Nowy Warsaw
    Posts
    3,934

    Default

    innalillahi......ugghh.....just R.I.P

    - - - Updated - - -

    innalillahi......ugghh.....just R.I.P

  4. #4

    Default

    Quote Originally Posted by Sybaris Caesar View Post
    innalillahi......ugghh.....just R.I.P

    - - - Updated - - -

    innalillahi......ugghh.....just R.I.P
    He was a good man... :'(
    He only sought to bring joy to this, otherwise, bleak and dreary world.
    May he find peace in the afterlife. RIP.

  5. #5
    Member
    • Sybaris Caesar's Gadgets
      • Motherboard:
      • Intel DH61WW B3 Rev.
      • CPU:
      • Intel Core i5 2400 3.10 Ghz
      • RAM:
      • Kingston KVR1333D3N9/4G 4GB DDR3 1333 Mhz
      • Hard Drive:
      • Seagate Barracuda 7200.12 1TB 7200 RPM
      • Graphics Card:
      • Leadtek Winfast GTX 560 ti 1GB GDDR5 822/1644/4008
      • Sound Card:
      • Onboard
      • Keyboard:
      • Thermaltake Commander
      • Mouse:
      • Logitech G402
      • Controller:
      • Original Xbox 360 Wireless
      • Power Supply:
      • Cooler Master G550M
      • Optical Drive:
      • Samsung SH222 22x DVD Writer
      • UPS:
      • Orlando 800va(packet e lekha apollo)
      • Operating System:
      • Windows 8.1 Pro x64
      • Upload Speed:
      • ∞
    Sybaris Caesar's Avatar
    Join Date
    May 2012
    Location
    Nowy Warsaw
    Posts
    3,934

    Default

    Quote Originally Posted by Ayat Ahmed View Post
    He was a good card... :'(
    He only sought to bring joy to this, otherwise, bleak and dreary world.
    May he find peace in the afterlife. RIP.
    Amen to that brother. May he find comfort with 70 virgin graphics cards in heaven :')

  6. #6
    Member
    • NahyaN's Gadgets
      • Motherboard:
      • Gigabyte H61M-S2V-B3/ Thermaltake Spacecraft VF-1 Chassis
      • CPU:
      • Intel Core i5 2400 with Coolermaster Hyper 212 EVO
      • RAM:
      • TeamElite 8GB (2 x 4GB) DDR3 1600MHz
      • Hard Drive:
      • Samsung 500GB (Primary)/ WD Caviar Green 2 TB (Storage)
      • Graphics Card:
      • Sapphire Radeon R9 380X Nitro
      • Display:
      • Samsung 19 Inch LED Monitor
      • Sound Card:
      • Built In
      • Speakers/HPs:
      • AudioTechnica ATH-M40X
      • Keyboard:
      • A4 Tech Multimedia Keyboard
      • Mouse:
      • Logitech G402
      • Controller:
      • XBox 360 Controller
      • Power Supply:
      • Delta 550w
      • Optical Drive:
      • LiteOn DVD-RW 22X
      • USB Devices:
      • Transcend 250GB Portable HDD
      • Operating System:
      • Windows 10 x64
      • Comment:
      • Seren1ty gets the job done. Period.
      • ISP:
      • Earth Telecommunications
      • Download Speed:
      • ~2 Mbps
      • Upload Speed:
      • ~2 Mbps
    NahyaN's Avatar
    Join Date
    Feb 2009
    Location
    Dhaka
    Posts
    541

    Default

    I still have my old (dead) Radeon HD4650 on display in my bookshelf. Ah those memories. Playing FarCry 2 at 20fps .

  7. #7
    Moderator
    • minitt's Gadgets
      • Motherboard:
      • Asus Sabertooth Z170 S
      • CPU:
      • Intel Core i7 6700K
      • RAM:
      • Corsair Vengence 3200mhz White Led
      • Hard Drive:
      • Samsung 830 (128GB) +1TB HDD
      • Graphics Card:
      • GTX 780 With Titan HS
      • Display:
      • Samsung KS8000 55"
      • Sound Card:
      • On board
      • Speakers/HPs:
      • Yamaha Reference Monitor
      • Keyboard:
      • Logitech G710+
      • Mouse:
      • Logitech G900 Chaos Spectrum
      • Power Supply:
      • Antec HCG-620M Modular
      • Optical Drive:
      • Nai
      • UPS:
      • dont need 1
      • Operating System:
      • Genuine Windows 10
      • ISP:
      • Shaw Cable
      • Download Speed:
      • 94Mbps
      • Upload Speed:
      • 20mbps
    minitt's Avatar
    Join Date
    Feb 2008
    Location
    dhaka
    Posts
    4,055

    Default

    Quote Originally Posted by Ayat Ahmed View Post
    I have a Sapphire HD 7750. I overclocked it once or twice without any problem. Anyway, 1 month later, I started seeing weird pixelation in 3D models. It only happens when rendering 3D models. To understand my problem, check this image link:
    Click image for larger version. 

Name:	JqkIYlM.jpg 
Views:	1310 
Size:	157.5 KB 
ID:	36219
    I tried sweeping the drivers and re-installing them. My GPU runs at about 43C under load. Is my GPU gone for good? If this happened to anybody else and you got it fixed, please let me know. Also, does anybody know good repairshops who can fix GPUs? I heard their life can be prolonged anywhere from a week to 6 months. Prolonging 3 months will do until i get a new one. Thanks in advance.
    try downclocking the gpu and see if the 3d pixel corruption is still there or not.

    - - - Updated - - -

    my 6 year old HD 4850 still performs like a champ in my friend's pc.

Similar Threads

  1. Is it dead!
    By CODhunter in forum GPU
    Replies: 12
    Last Post: September 10th, 2013, 04:24
  2. Sale (Used) dead 0cZ 600 psu
    By Dna Mex in forum Shop - Gadgets
    Replies: 8
    Last Post: June 28th, 2013, 23:58
  3. 2nd PS3 DEAD !!
    By MW3 in forum PlayStation
    Replies: 17
    Last Post: July 10th, 2012, 03:04
  4. is tbh dead?
    By S_F.darkzone in forum File Sharing and Torrents
    Replies: 20
    Last Post: June 9th, 2011, 13:23
  5. Closed Laptop and a dead/half dead nokia n72
    By avas911 in forum Shop - Gadgets
    Replies: 4
    Last Post: December 4th, 2009, 00:11

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 0.19957 seconds with 15 queries.